LDraw.org Discussion Forums

Full Version: DATHeader
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
I just release version of DATHeader.
This is only a bugfix version that should have been uploaded much, much earlier.

Please leave all comments for this version as response to this topic.

Have fun.
Download from DATHeader Webside
On initial start, the application shows an error:

"Error in modXML.ini.XMLRead
The path is not of a legal form."

with just an OK button.
Maybe, the tool tried to read an XML file of a previous version.
I think it should succeed in that, not fail, hoping that these XML files carry
a version number inside, so newer software gets able to read old ones.

After clicking OK, the "Preferences" dialog shows up unasked.
Funny: it shows a "License Type" dropdown box with 0 entries.
I anyway entered some preferences and then clicked "Save".
Another error shows up:
"Error in procedure cmdSave_Click of Formular frmOption
The process cannot access the file
because it is being used by another process"

However, there's no other DATHeader instance running, just this one.

Each time I click "Save", this happens.
So my only resort to close this dialog is clicking "Cancel", but then DATHeader crashes:
  Stopped working

Problem signature:
  Problem Event Name:   CLR20r3
  Problem Signature 01: datheader.exe
  Problem Signature 02:
  Problem Signature 03: 4fae0dc0
  Problem Signature 04: mscorlib
  Problem Signature 05:
  Problem Signature 06: 4ef6c7cc
  Problem Signature 07: 3452
  Problem Signature 08: 21c
  Problem Signature 09: System.IO.IOException
  OS Version:  6.1.7601.
  Locale ID:   1031
After this, DATHeader has created a datheaderini.xml file in my Windows User "My Documents" folder,
with all-empty settings.
This way, also my old DATHeader version (3.0.5) now no longer has valid settings :-(
I have now manually deleted that file.
This does not help:
Running DATHeader 3.0.5, my old version, shows error:
"Error in InitTranslationsObject reference not set to an instance of an object.".
However, after that, the main application window comes up and lets me re-enter my preferences.
DATHeader still shows the behaviour described in my previous post.
I also do not understand why DATHeader brings its own copy of LDconfig.ldr.
It IMHO should use the one from the LDRAW root folder.
I don't want multiple copies of that file...
Why? One's bad enough? ;-)
Sorry for answering so late.

Information about your system would be great next time.

After checking the code, I assume that you had a datheaderini.xml in the same folder than DATHeader. I discovered a bug if this is present. I'll send the changed version by PM to you.
I tried here to get the same error, but without success. All is working fine here.

All new versions of DATHeader can read "old" datheaderini.xml and do update them for the new version (no version check for the xml file). I doubt that old versions can work with that changed version then (never tested).
Regarding the double LDConfig, please think about that many people that tweak that file for their personal benefit. DATHeader can not work with such customized files and needs its own version, that can be updated by Menucommand to download the latest version of LDConfig from official place.
I wondered too, but you have a very good point!
Now that the spec is online I like to tell you that a basic check for !TEXTMAP section is already build into DATHeader Smile

If it does not work like you suggest, please let me know.
Pages: 1 2 3