LDraw.org Discussion Forums

Full Version: Save CPU/GPU in LDCad when Editing Large Models?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is there a way to make the rendering a little cheaper in LDCad to save a bit of graphics power? I know I'm not using official computer terms, so it might get a little confusing, but I just want to know whether there's a way of making the curves less round in order to make it easier for a good-but-not-so-good computer to render the model in real-time in LDCad... A bit like the "Curve Quality" slider option in LDView?
See my computer doesn't have a GPU, so there's an adapter that allows the monitor to be dealt with by the CPU, which is an Intel Core i2 (if you never heard of it, that's because they don't even make them anymore ?.) Surprisingly, I've been using LDraw programs for quite a while now and always managed to work around this problem... But now I'm dealing with a model which has several baseplates and I'm planning on adding a few buildings as well, so it would be useful if I could avoid playing with fire ?... Already getting slow on the rendering and getting stuttery model rotation (if stuttery is a word, but I yeah.)
Thank you in advance for any help.

P.S. Maybe an alternative to my problem could be using another LDraw editor? I would be sad to have to change editors since LDCad is really my favourite so far but, if it works, I'd be OK with that too...


--
G.D. Grant
(2021-09-26, 21:52)G.D. Grant Wrote: [ -> ]Is there a way to make the rendering a little cheaper in LDCad to save a bit of graphics power?

Judging from your story you are using a software OpenGL rendering platform.

LDCad's rendering engine doesn't really use any fancy things effects wise so your biggest bet would be on reducing the amount of data/work send to OpenGL

You could try:

- Set vertex processing to "minimal"
- Disable all edge lines.

Both options can be controlled using the prefs/LDraw menu.

Next you could try to minimize the rendering frequency.

This is done by disabling 'hottracking' in prefs/OpenGL

Last you could try disabling the anti alias feature, but it might already be disabled resulting from a low OpenGL version.

It is the last option in the prefs/LDraw menu.

As a very last resort you could try disabling lighting, but without edges the rendering might be just a blob of colors.
(2021-09-27, 22:00)Roland Melkert Wrote: [ -> ]Judging from your story you are using a software OpenGL rendering platform.

LDCad's rendering engine doesn't really use any fancy things effects wise so your biggest bet would be on reducing the amount of data/work send to OpenGL

You could try:

- Set vertex processing to "minimal"
- Disable all edge lines.

Both options can be controlled using the prefs/LDraw menu.

Next you could try to minimize the rendering frequency.

This is done by disabling 'hottracking' in prefs/OpenGL

Last you could try disabling the anti alias feature, but it might already be disabled resulting from a low OpenGL version.

It is the last option in the prefs/LDraw menu.

As a very last resort you could try disabling lighting, but without edges the rendering might be just a blob of colors.

I couldn't thank you enough, Mr Melkert. LDCad is running a lot smoother now.
Indeed the antialiasing setting can only be set to either "edges only" or "none," as you had predicted.
Thank you again for your help. It's most appreciated.


--
G.D. Grant