LDraw.org Discussion Forums

Full Version: LDCad 1.6a (win+linux)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Hello Roland. I see new update of parts is released, what recalled me the question of snap data for the previous one. Please, do you have it ready and is it downloadable somewhere? Maybe I missed a link (if it was in the middle of some thread only). Thanks!
(2018-01-31, 11:08)Milan Vančura Wrote: [ -> ]Hello Roland. I see new update of parts is released, what recalled me the question of snap data for the previous one. Please, do you have it ready and is it downloadable somewhere? Maybe I missed a link (if it was in the middle of some thread only). Thanks!

I processed the 1701 library in preparation of 1.6b, I also made some changes to the bin which I posted here:
https://forums.ldraw.org/thread-22656.html

I will also make shadow files for the new 1801 lib before releasing 1.6b (will cause a slight delay in its release though).
(2018-01-31, 18:18)Roland Melkert Wrote: [ -> ]I processed the 1701 library in preparation of 1.6b, I also made some changes to the bin which I posted here:
https://forums.ldraw.org/thread-22656.html
Thanks, this is what I installed. I see some changes in part bin structure but snapping is still missing for new parts. For example 24299 (missing antistuds on bottom).
And I was surprised the zip file contains .sf files for seeds/ directory only, I expected an update of shadow/ directory as well - this is how I came up with (probably wrong) assumption the snap info is not a part of that .zip file and I need to get an extra update... ?
(2018-02-01, 13:03)Milan Vančura Wrote: [ -> ]
(2018-01-31, 18:18)Roland Melkert Wrote: [ -> ]I processed the 1701 library in preparation of 1.6b, I also made some changes to the bin which I posted here:
https://forums.ldraw.org/thread-22656.html
Thanks, this is what I installed. I see some changes in part bin structure but snapping is still missing for new parts. For example 24299 (missing antistuds on bottom).
And I was surprised the zip file contains .sf files for seeds/ directory only, I expected an update of shadow/ directory as well - this is how I came up with (probably wrong) assumption the snap info is not a part of that .zip file and I need to get an extra update... ?
That package contains shadow.sf which is the seed for snapping info.

Seed files are simply my solution to the multi user environment thing, they are renamed zip files with the default settings for partibin, colorbin, shaow etc. They will auto extract when the matching root folder (as set in LDCad.cfg or besides the main exe if no cfg is present) doesn't exist (first start for this user) or when the last extraction date is older then the .sf timestamp.
(2018-02-01, 20:32)Roland Melkert Wrote: [ -> ]
(2018-02-01, 13:03)Milan Vančura Wrote: [ -> ]Thanks, this is what I installed. I see some changes in part bin structure but snapping is still missing for new parts. For example 24299 (missing antistuds on bottom).
That package contains shadow.sf which is the seed for snapping info.
Yes. I can look into them on filesystem - like into any other zip file. And I see that shadow.cf contains 24299.dat file with the snap definition I'd expect (two antistuds at part bottom). But after I put all these .sf files into seeds/ subdirectory and start LdCAD, I see no antistuds there for part 24299. Checked with "show snap info" function (F12).
Is there any special action I need to do? Or LdCAD setting?

I expect that it starts to work when I extract .csl file from the .sf file manually and put it into shadow/ directory (replace the old/original version of the same file). But why it does not work with seeds/ directly?
(2018-02-01, 23:07)Milan Vančura Wrote: [ -> ]
(2018-02-01, 20:32)Roland Melkert Wrote: [ -> ]That package contains shadow.sf which is the seed for snapping info.
Yes. I can look into them on filesystem - like into any other zip file. And I see that shadow.cf contains 24299.dat file with the snap definition I'd expect (two antistuds at part bottom). But after I put all these .sf files into seeds/ subdirectory and start LdCAD, I see no antistuds there for part 24299. Checked with "show snap info" function (F12).
Is there any special action I need to do? Or LdCAD setting?

I expect that it starts to work when I extract .csl file from the .sf file manually and put it into shadow/ directory (replace the old/original version of the same file). But why it does not work with seeds/ directly?
The .sf only updates the .csl, but it seems you are using the shadow library unpacked. If so you'll need to manually unpack the updated csl again. It's probably better to first delete the old unpacked folder as I have deleted some files because those parts who have been moved/renamed in the new library (~moved in description)
Bug report:

If you have an invalid path set for the shadow library of the official library, LDCad crashes with no error upon navigating to parts bin where an official file thumbnail is generated.
(2018-02-11, 4:48)Orion Pobursky Wrote: [ -> ]Bug report:

If you have an invalid path set for the shadow library of the official library, LDCad crashes with no error upon navigating to parts bin where an official file thumbnail is generated.
What filename were you using? as I can't get it to crash by setting non existing shadow locations, also the log reported a "could not locate ...." in such cases.
I also tried setting a non zip as a csl but gives only gives a "invalid zip file" message dialog without.
(2018-02-11, 19:54)Roland Melkert Wrote: [ -> ]
(2018-02-11, 4:48)Orion Pobursky Wrote: [ -> ]Bug report:

If you have an invalid path set for the shadow library of the official library, LDCad crashes with no error upon navigating to parts bin where an official file thumbnail is generated.
What filename were you using? as I can't get it to crash by setting non existing shadow locations, also the log reported a "could not locate ...." in such cases.
I also tried setting a non zip as a csl but gives only gives a "invalid zip file" message dialog without.

Hmm. That’s what I changed to solve the crash but maybe that wasn’t the real cause. I’ll try to reproduce when I get home.
Small question: why is the rendering of part 24246 so weird in LDCad (see attached image)?
It's doing weird things with the shadows and it almost looks like the part is some kind of metallic, but it's just standard LBG like the other parts in the image.
Pages: 1 2 3 4