LDraw.org Discussion Forums

Full Version: [LDPartEditor] 0.8.31 Beta Released (!LPE VERTEX / Usability / bugfix)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3

I fixed ten issues within the last week, so... here is a new release Smile

[Image: imgDuke2.png]
As always, you can download LDPE from this page:

(6 new features and 4 bug fixes)

With this release you will be able to...
  • ...delete a !LPE VERTEX without "Move Adjacent Data" being on.
  • ...see the selection of !LPE VERTEX meta commands (3D -> text).
  • ..."Show Selection In 3D View" of a !LPE VERTEX line in text editor.
  • ..."Show Selection In Text Editor" of a !LPE VERTEX line in 3D view.
  • ...add a !HISTORY line quickly in the text editor (with Ctrl+H).
  • ...add a !KEYWORDS line quickly in the text editor (with Ctrl+K).
The following critical issues were fixed:

  1. YTruder accidentally deleted the selected lines.
  2. YTruder was not able to do symmetry or projection on planes with value=0
  3. Toggle comment / !TEXMAP freezed the text editor on empty lines.
  4. SyncEdit did not mark the !LPE VERTEX meta command.
What will the next release 0.8.32 deliver? Bug fixes, more header validation features, usability improvements...

The program was tested intensively with "real world" files.
However, it is still a beta version and something can go wrong in about 100.000 lines of code.

Make sure that you choose the right architecture for your OS and Java Virtual Machine (JVM) (64bit or 32bit).
A short guide how to check if a 64bit JVM is installed on your system is located at the bottom of this message.

  1. Download the zip-Archive
  2. Extract the archive content to the location of your choice
  3. On windows, double-click "run.bat" to start LDPE.
  4. On linux, you have to excecute the shell script "run.sh" to start LDPE.
Please note that this software is in the beta stage. Although, this version was tested, there are already known issues  for this release. There is a potential risk of data loss.

You can search for updates if you do the following steps:

  1. On windows, double-click "update.bat" to search for updates.
  2. On linux, you have to excecute the shell script "update.sh".
I listen carefully to your requests and possible complaints. Please leave me a message, with your thoughts and wishes to further improve the software.

LDPE is a 3D CAD application: The overall system requirements are higher. While I recommend to use a powerful 64-bit multicore system, it could be possible, to run LDPE on older machines as well.

System Requirements:

Minimum System Requirements:
  • 64-bit Java Runtime Environment (JRE) 1.8
  • OpenGL 2.1 compatible Graphics Card
  • Operating System (64-bit): Windows [7 or newer], Linux [e.g. Ubuntu Linux >=14.4]
  • CPU: Multicore-Processor e.g. Intel Core 2 Duo or AMD Athlon II (>2.0Ghz)
  • RAM: 4GB
  • Video-Memory: 1 GB
  • Free Disk Space: 100 MB
Recommended Requirements:
  • Operating System (64bit): Windows 7,8,10, Linux [e.g. Ubuntu Linux >=14.4]
  • OpenGL 3.3 compatible Graphics Card
  • CPU: Multicore-Processor with 4 cores (or more)
  • RAM: >4 GB
  • Video-Memory: >1 GB
  • Free Disk Space: 512 MB
  • For a faster start, LDPartEditor and the LDraw™ library should be installed on a SSD.
How to check your JVM version (32- or 64-bit):

You can try on the command line:

java -d64 version

If it's not a 64-bit version, you'll get a message that looks like:
This Java instance does not support a 64-bit JVM. Please install the desired version.
Thanks  Smile
When using the translate/scale/set etc actions, an axis thingy is displayed to show origin and orientation, which is a Good Thing. But the displayed thingy is always the local one, even if we are in global mode. And there it becomes misleading!

Otherwise, I see that I mistakenly put may last two posts in 0.8.28 thread instead of this one... and I didn't find how to move them.
Another conveniency one...

As a user, I'd like to be able to remove all "0 // Inlined:" notices with a "quick fix".
As a user I want to move the Manipulator with left/right or up/down arrows on my keyboard.

Something like this:
  • select something, a vertex/line/surface/prim.
  • set Manipulator position
  • set move/rotate/scale step/distance/angle
  • "mouse over" one of the axis on the Manipulator
  • move one step by pressing left/right or up/down arrow key once
Select by mouse click and drag'n'drop is difficult when I only want to finetune something.
This, select and move something, is possible in LDPC. Why not in LDPE?
I'd appreciate keyboard movements too...
Looks like LDPE embedded Edger2 sometimes creates erroneous edge lines in flat areas... Attached the original file, result with command line Edger2, result with LDPE Edger2. Problem occurs near the tread rounded tips of tread. Default parameters, no generation of unmatched lines.

Found the culprit: overlapping surfaces. I was fooled because minute rounding errors made these overlaps unnoticed by LDPE duplicate detection engine.
When I double-click "run.bat", the document flashes back. What's the matter?
(2017-05-24, 2:38)yongxu wang Wrote: [ -> ]When I double-click "run.bat", the document flashes back. What's the matter
It has been solved。Now learn how to use it
(2017-05-24, 4:36)yongxu wang Wrote: [ -> ]
(2017-05-24, 2:38)yongxu wang Wrote: [ -> ]When I double-click "run.bat", the document flashes back. What's the matter
It has been solved。Now learn how to use it
Good luck Wink What was the problem? Incorrect installation of JRE?
Pages: 1 2 3