LDraw.org Discussion Forums

Full Version: LDCalc not running on Win 10
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

had anyone running LDCalc successfully under Windows 10. Tried tweak compatibility, rights, turned of antivirus, created a fake LDCalcIni.xml ... no chance.

Do I need some special runtimes?

Just a confirmation: it doesn't work here either (on Windows 10).
My antivirus is constantly saying it's a malicious file though.
That is really strange. If I download the latest version from http://ldraw.heidemann.org/index.php?page=ldcalc I get the same error than you.

If I run this in the development enviroment it works like it should.

If I copy the new build over the old file, I get the same error than before.

Currently I have no idea where to fix this issue.

I'll go to port this to the latest visual studio and hope the error will be gone then.

This may take some time.
It might be, that the file xmpd.dll needs to be in the same folder.
Merlijn Wissink Wrote:My antivirus is constantly saying it's a malicious file though.
You could report it as a false positive for exclusion, but the next version of LDCalc might trigger it again. I usually exclude such programs (if trusted) locally from the scanner.

Also Windows 10 (Home edition?) is known for its automatic protection and even removal behavior, which might also be at play here.
Adding a copy of xmpd.dll didn't fix the problem. Strangely the LDCalc version on the computer that got updated from Windows 7 to 10 DID work. It turns out that it is version

I copied that version over the LDCalc came also with a xmpd.dll and a LDCalcIni.xml. It WORKED.

I substituted the LDCalc.exe with LDCalc.exe After confirming that I'd trust the prog I got a message that the LDCalcIni.xml (that came with couldn't be read. After confirming I've got a running LDCalc.exe!!!

As far as I have understand this happens only once. Because I did not understand fully the certification process for trusted application I do not care about that. So Windows has no key that it knows the application should be fine. I encounter this for some application that i got from the internet. But after i accept the application the warning windows will not shown again.

But this is a different issue than the missing xmpd.dll that happens here.
Now I made a new build (no new features) with Visual Studio 2013.
I checked that it works after downloading (you will get the message from Smardscreen, so please allow this app.).

From my point of view all works fine now. I named it now version

You can download as usual from http://ldraw.heidemann.org/index.php?page=ldcalc
Works, thanks a lot!