LDraw.org Discussion Forums

Full Version: LDview: weird crash
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've made this file (it's set 7140), but I can't view it in LDview. It crashes immediately when it starts up (after double clicking the file). I think it must be one of the parts inside the X-wing, because I can view all the submodels separately except the X-wing. And, I downloaded a file from the internet based on the same set (altough it was old and incomplete) and it had the same problem with the X-wing.

Could someone try to open the file on their pc to see if it crashes there too?

I have Windows 8.1 Pro 64bit and LDview 4.2 Beta.
Doesn't crash here in either 4.1 or 4.2beta.

Displays fine too (after I downloaded the 1 unofficial part it uses).
With LDView 4.1 under Win 8.1 64 bit there is no problem with this file.
It doesn't crash for me either. It's possible that the crash is dependent on your settings, and it's possible that the crash is dependent on something strange in your LDraw directory. I'd be happy to investigate further if you do the following:
  • Export the HKEY_CURRENT_USER\Software\Travis Cobbs\LDView registry key and post the registry file to your Dropbox
  • Zip up your LDraw directory and do the same
  • e-mail the Dropbox links to the LDView email address
Note: my philosophy is that application crashes are always bugs. That doesn't mean I'll be able to track them down, and it doesn't mean I'll be able to fix them, but even if they are caused by obviously garbage input, they're still bugs. So, even though I'm asking you to send me your settings and your LDraw directory, I'm not doing that in an attempt to blame you for the crash. And I do my best to track down these bugs and fix them (although I'm not always successful). Also, built bug-fix binaries always go first to whoever reported the problem so that they can verify any fixes.
Thanks for your reply, Travis (and the others who reported that it does work at with their LDview).
I think it has something to do with the settings, I can view the model using all the presets, except my own and the quality with edges.

I'll send you my files. Do you still need the LDraw library, or is the key enough?
If it is settings-related, then the registry export should be enough. If I still can't get it to crash on my Windows 8.1 VM, I'll ask for your LDraw directory.
Well, it didn't crash for me, unfortunately.

Try setting the "Curve quality" setting to the second notch and uncheck the "Use hi-res primitives when available". If that makes the crash go away, then I suspect that you're running out of memory (possibly on your graphics card). If this is the case, it's likely that it's not something that's ever going to get fixed, even thought it is indeed a bug in LDView. It may in theory be possible for me to fix it to not crash, but the level of effort involved is very big, and there's no guarantee I'll succeed.

Another thing to try is to set the "Memory usage" setting to low or medium.
Lowering the curve quality fixes the problem. At the fifth notch, it crashes.
Although, I highly doubt I run out of memory on my gpu. I have a reasonable good gpu (although not the newest) with 1GB of memory. And, I can open much bigger files with a way higher curve quality with no problems (although it becomes a bit slow at some point Wink ).

At least, I can view the model in LDview, so thanks for the tips!
Pretty weird indeed. I tried your model, cranked up primitive substitution to the max. Frame rate dropped from 12 to 4 fps, but it worked fine (and my machine is not outstanding, by far!)
Well, I was browsing Space Police I models topic here on the forum, and I found another model which makes my LDview crash when I have the curve quality too high. It's this one, set 6886. Very strange.