LDraw.org Discussion Forums

Full Version: LDCad 1.3 (win+linux)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I just released the definitive 1.3 version of my LDCad.

At first I wanted to do another beta but during private testing I found it to be stable/complete enough to justify a definitive version.

Nog real big changes in this version, just bugfixes and two new minor features, namely:
  • Selection information (demo youtube clip)
  • Optional XY camera rotation (as an alternative to the default trackball)

I've also added snap information to stacks of official parts, resulting in the 'sorted/bicks' and 'sorted/plates' part bin sub trees having full snap info.

No new examples, but I've been working on this one myself.

[Image: 1-3-ForumScrShot.png]

Latest version can be found at www.melkert.net/LDCad as usual. You can install it over any recent previous version.

Linux note:

With this version I moved from compiling on Unbuntu 10.04 to compiling on Kubuntu 12.04, this should fix most of the compatibility problems on e.g. suse etc.
How did you solve the displacement problem of the two universal joints for steering? When I tried to build it with MLCad and calculate these angles manually, I didn't got correct results. So that the U-joint near the steering was never correct connected with the steering column. Undecided
When I look at my real model, the steering wheel is a bit rotated even when the wheels are in a straight driving position. That's why I wonder, when I look at you picture...

I have to say great work on the software and thanks a lot for the Linux support. The brick snapping and ghosting are really helpful to me and worked really well in my limited testing in the beta. I just happened to run check for an update last night and I have an issue running the 1.3 release. On Ubuntu 12.04 32bit I get an error of "FATAL: OpenGL not available" that may not be exactly right but some very close to that, I will check when I get home from work and update the error.

The beta ran just fine on the same box. I did install some other gl packages but I was really just guessing at that point and it did not seem to help. If I try to open a file instead of just opening the application it segfaults and core dumps. Just one more data point I tried to load it on my work computer RHEL 6.5 where the beta also works, I don't have the correct glibc (this I understand since you updated your build host, I was just trying to see if I got the same error).

Again thanks for you work, I am really enjoying LDCad.

Actually the double uni joint was the reason I added the selection information feature. With it you can determine the exact angles for placement.

I did cheat concerning the roll you mentioned, although it should be possible to also determine those angles using the new info in combination with helper parts in some smart way.
This is very weird given I compiled on Kubuntu 12 which should be the same (core wise) as Ubuntu 12 (I really don't like unity Smile ) I did test the new version on Ubuntu 13 (64 though) and it seemed fine.

OpenGL initialization hasn't changed since the beta, so this is probable a dependency problem. Do your machine has 'real' OpenGL or is it using mesa only?

Could you send me the logfile(s) maybe they indicate the exact problem (probably GLEW though).
melvinpelvinosk Wrote:On Ubuntu 12.04 32bit I get an error of "FATAL: OpenGL not available" that may not be exactly right but some very close to that

It did work for me on ubuntu 12, but I ran into the same problem on xubutu and fedora. I manged to trace this problem to wxWidgets 3.0 somehow.

It seems the main window isn't fully visible when I try to init the OpenGL context so it fails. I have a workaround in a test build but it isn't pretty (it shows an message box and inits after you click ok on it thus making sure the frame is visible).

I'll try to find a better solution this weekend.
Thanks, I will be happy to test your fix. If you still want some logs let me know and I can provide them but it sounds like the same issue I came across.

I think I have fixed it could you please try one of these:


This should fix the OpenGL context problem, the libc dependency remains the same. I tried compiling statically but that gave all kinds of linker problems.
That fixed it. Thanks for the quick fix.

Roland Melkert Wrote:I've also added snap information to stacks of official parts, resulting in the 'sorted/bicks' and 'sorted/plates' part bin sub trees having full snap info.

Is there anything we mere mortals can do to help there? I'm missing the snap information in parts like 3660 (the top snaps, but not the bottom). Also, would it be possible to have parts snapping side-to-side too?
Pages: 1 2