LDraw.org Discussion Forums

Full Version: 98284.dat error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

I have just found out that the part 98284 has an error. The center is show way of to the side.
I have just downloaded the newest complete.zip file from this site and the file included has the same error.
I have manually corrected this on the .dat file.
But when i start both ldview and lpub the bot still show the part with the center at a wrong position.
Does anyone know how i get lpub and ldview to show the part correct?
You mean "Plate 2 x 2 Round with Hole and 4 Vertical Bars"? Part origin looks good to me. Have you got a screenshot showing the problem?
Here is what it looks like, when unpacked from complete.zip (just downloaded from this site)
Here is after i corrected the dat file:
Here is what it looks like in LPUB (after correction of dat file)
and in LDview:
I just downloaded the file from the official library and can not see any fault in this part.

Please check all occurence of the part no. 98284.dat on your system (official path, unofficial path, etc.).
It seems to me that you have an incorrect part on your system.
Hi Michael

Thanks for the suggestion, but i have now searched the intire ldraw library for any dat file containing 98284 and only two files are found: 98284.dat and 973pa8.dat (a minifig torsoe).

Instead i have fixed the problem by doing the following:
1. rename my existing p and parts folder.
2. extract p and parts folder from complete.zip.
3. copy over all files from the old p and parts folder - skipping existing files.
4 run mklist.

Thanks for the help.
Yes, that is good.

Sometime it's a subfile of a subfile that is wrong. To find such an error is very difficult. That's the reason why I do not mix unofficial and official files Smile

By the way, LDStructure might be a helping hand in these situations.

Thanks for the tip. Thats a nice set of tool on the page you linked to.
I will try them out.

I have now - finally testet the LDStructure program you suggested. I have had a server breakdown the last couple of months that i have just recovered from :-(

Anyway, as i can see in LDStructure, the part is show correct, but it is still not in both LPub and LDView.
MLCAD shows it correctly.
What can i do to correct this?

Kind Regards
Since LDStructure uses LDVLib.dll for its rendering, I think that the LDraw directory set in LDView isn't right, while the one in LDStructure is right. (LDVLib.dll is a DLL-based copy of LDView's rendering engine, basically a DLL wrapper around the exact same source code used by LDView itself. So it should produce a 100% pixel-perfect duplicate of what LDView produces, when set to have the same options.)

Knud: In LDView, select File->LDraw Dir..., then make sure it's set to the directory you have set in LDStructure. If it looks like it's the same, please look very closely to be absolutely sure, because I've had people in the past say their LDraw directory was set correctly in LDView, when in fact it wasn't.

Thanks for the reply.
I have now double checked the path, and it is exactly the same: C:\program files(x86)\ldraw
I have just to test it tried to change it to an older backup of my ldraw folder: c:\Program Files (x86)\LDraw - Copy 2012-01-05
This fixes the issue in LDView, but introduces the error in MLCAD instead.
It seems that MLCAD and LDView interpred this part differently

It looks to me as it is the "sub part" stud4h.dat that is misplaced.

Kind Regards
Pages: 1 2