LDraw.org Discussion Forums

Full Version: Submodel not displayed in Lpub...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I need help to fix a problem in Lpub.
In my main model, I call two times a submodel. The second time it appears correctly, but the first time it doesn't appear. In fact it appears but only a few steps later after a model rotation.
In the same main model, I call two times another submodel, and it works fine !
I don't understand what happen. I tried to delete the submodel and to re-create it, but the problem is still there.

Is there anybody who have already seen that ? or know what I could have done wrong ?

Thanks in advance for your help.

I've had this problem myself and as far as I can tell the only solution is to make two identical submodels and call each of them once. Or add them both at the same step.

I think it happens when the meta-commands surrounding it are of a certain form but I won't swear to that.

Thanks a lot Tim,
I will experiment the two solutions and will let you know as soon as I did it.

I tried to call the sub-model two times in the same step but in case, it doesn't work.

I finally fixed the problem using your first solution Tim. I created a copy of the submodel and I call it separately.

Thanks again for your help,
Glad it works.

Slightly off-topic but it usually pays to learn how to use LPub by hand edited meta-commands (including learning the quirks of steps). The GUI sometimes gets things a bit wrong (unsurprising since it's very hard to automate) and knowing what it should look like lets you hand edit it to be correct.

Could you sent me your original LDraw file where it went wrong.
I am interested to see what the problem might be?