LDraw.org Discussion Forums

Full Version: cant render 16 tooth clucth gear with pov ray 3.7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Does any one know why Pov Ray wont render the Technic Gear 16 Tooth with Clutch Smooth/ and not smooth.
It will get to this point and stop
object {
LDX_48_slash_4_dash_4ri100_dot_dat_in_part (this line highlighted in yellow)
matrix <0.17,0,0,0,0,-1,0,0.17,0,0,0,10>
I have updated the part list and also tried updating just this part. LDview shows it just fine.
Cheers Jono
Take a screenshot of the POVray message pane where the warning is made.
Take a screenshot of your POV file where the bug occured.
There's a known (by me) bug in LDView that is probably responsible for the error you see. I think if you remove the "_in_part" from the line, it will work. If not, if you send me your POV file, I'll see what fix can make it work.

Assuming this is the known bug, it is something that I have fixed in my development code, but not yet released.
That worked. Thank you for your time and help. Simply removing that line and it rendered it.
Cheers Jono
You're welcome.

Note: removing the whole line will make it render, but there will be a missing ring in the final image (which may or may not be visible, depending on your camera position). Removing "_in_part" from the line will hopefully make it render without removing any geometry.
after updating Pov Ray to 3.7 this fixed some errors that 3.6 had. then a post on Eurobricks came up with another soulution:


and in the "Replace with" field enter:


I did this with them all and almost got to the end of the file. The person said that it was ans export error from LDraw to Pov Ray.
Now it stuck on this line
Thank you for your help.
Cheers Jono
I checked a .pov file with this gear, visually. The primitive in our Library is named 4-4ri100.dat (that's what is written in the declare section). But in the object section (where the model is described) there it is written as 4-4rin100.dat .
So this is indeed a problem caused by the LDView export (I assume, that Travis didn't expect ring prims bigger than 99 LDU :-)

So the correct way would be a search for
and replace it with
(Just for getting the LDraw file and pov file comparable. Your way is working as well, of course.)

Can you attach your Ldraw file, I have no idea, which part is called within the next problematic line?! Thanks!

Don't think it has anything to do with 99.

I've always had the same problem with part 4150ps4.dat where:

need fixed with:

I usually just use a script to fix the .pov file automatically by adding these:
#declare LDX_1_dash_16ri19_dot_dat_in_part=LDX_1_dash_16rin19_dot_dat_in_part;
#declare LDX_1_dash_16ri19_dot_dat=LDX_1_dash_16rin19_dot_dat;
Well, the problem is, that we have (had?!) a restriction that a primitive file name must be not longer than 8 characters. This causes some problems. Normally a ring prim is named after this scheme:
but some combinations are not really possible: for example a nn-ffrirr.dat would be to long and a nn-ffrrr.dat looks quite odd (and could be misinterpreted, if there would be another primitive starts r
Same thing for numbers bigger than 99. The are not in this scheme and will cause in a problem. And so on...

Now we should NEVER need ring 100 ! it's so thin, it's just a matter to approximate dimenrsions a bit.
That appears to be another LDView bug, but I'm not sure if this is one I've fixed in my dev code yet or not; I'll be sure to fix it if not.

Do another global search and replace. Look for this:


Replace it with this:

Thanks for posting that fix suggestion, Stephen. Please note that you can probalby put that stuff into a file in your POV-Ray include path, then set the top include option in LDView's export options. Then you wouldn't have to run your script every time.
Yes, I probably could have put it into a top-include in LDView, but I'm already using scripting for a load of other modifications too.
I stumbled upon that fix and also just deleting the comma, both ways worked. And finally I managed a render woohoo.
Thank you all again for all the help on this. Cheers Jono
Max Martin Richter Wrote:a primitive file name must be not longer than 8 characters

LOL. What century are we in?