LDraw.org Discussion Forums

Full Version: How to import MLCad.grp?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I installed MLCad 3.40 a while ago but didn't bother with importing MLCad.grp. How do I do so now? I've copied the file into MLCad's directory but MLCad ignores it as far as I can tell. Thanks.
What do you need MLCad.grp for? All tree definitions have been moved to the registry:

HKEY_CURRENT_USER\Software\Lachmann\MLCad\GroupDefs

in 3.40. MLCad.grp has become obsolete. Read Tweaking the Parts Tree

w.
Supposedly there's a way to import your MLCad.grp.

https://sites.google.com/site/workingwit...40released

Unfortunately I can't get it to work. There must be a flag in the registry that says "Program ran for the first time".
I think that this flag is simply the answer to the question: is the group section already in the registry.

I might be wrong, but from coder point of view this makes a lot of sense.
Crap. The Parts Tree Configuration dialog is tedious. There's no "Add a Search String" button. Instead you have to open the dialog, type in what you want, close the dialog, open the dialog again and then move the string up or down in the list if needed. Repeat.
This is why I really don't like programs that use the registry and have shunned it in favor of .ini files for all of my programs such as LDDP.
Totally agree! Though I guess it's possible to explore MLCad data with regedit?
Can't he just put the configuration data in the User\AppData folder or wherever it is "safe" to write files?
I would like to know too. Maybe it's easier to manage the categories there.
I've found two occurence of what you are looking for:
HKEY_CURRENT_USER\Software\Lachmann\MLCad\GroupDefs
HKEY_USERS\S-1-5-21-3369456988-2834548598-986560021-1002\Software\Lachmann\MLCad\GroupDefs

Currently both seems to be identical.

Edit:
I changed a bit in the registry and started MLCad. The changes has been available.
Then I clicked by error or "default".
Both entries are still the same, but I see only the default.
I can not see any flag that results in this behaviour. Sad
Pages: 1 2