Welcome! Log In Create A New Profile

Advanced
Call for Votes: Make MPD support required
avatarJanuary 18, 2013 02:24PM
Please vote on the proposal below. Please modify the Subject to include your name and vote, in addition to giving your vote in the text.



Change the LDraw File Format spec:
  • Update the LDraw file format version number to 1.1.0. Note: 1.1.0 was chosen instead of 1.0.2, as this change was thought to be too big for such a minor version number change.
  • Add the following sub-section under the "Basic parsing / file content" sub-section of the "LDraw Files" section:
    Quote

    Multi-Part Dat (MPD)
    Any LDraw file, no matter its file extension, may be a Multi-Part Dat file (file with other files wrapped inside). This is done using the MPD Language Extension.
  • Change the "MPD Statements" sub-section of the "META Commands" section to be as follows:
    Quote

    Support for the MPD Language Extension is required.

Also, update the File Format Restrictions for the Official Library spec. Add the following new paragraph to the "META Commands" section directly above its last paragraph (the one starting with "Legacy parts"):
Quote

To reiterate: No other meta-commands (including the MPD meta-command) are allowed in official parts.
SubjectAuthorViewsPosted
Call for Votes: Make MPD support required Travis Cobbs802January 18, 2013 02:24PM
Travis Cobbs: YES Travis Cobbs299January 19, 2013 03:28PM
Roland Melkert: YES Roland Melkert288January 20, 2013 10:35AM
Allen Smith: YES Allen Smith249January 22, 2013 09:12AM
Re: Call for Votes: Make MPD support required - Chris Dee: YES Chris Dee259January 25, 2013 12:44AM
Re: Call for Votes: Make MPD support required - MOTION PASSES Travis Cobbs343January 25, 2013 04:15PM
Re: Call for Votes: Make MPD support required - MOTION PASSES Willy Tschager472February 08, 2013 01:01AM



Sorry, you do not have permission to post/reply in this forum.