Welcome! Log In Create A New Profile

Advanced
Re: AIOI problem when installed on a drive other than C:\
June 15, 2013 03:24AM
I did some investigation on this:

The POV installer writes an installation-path based on the version in say:

HKEY_CURRENT_USER\Software\POV-Ray\v3.6\Windows

After you've launched POV for the first time a second key with path information gets created:

HKEY_CURRENT_USER\Software\POV-Ray\CurrentVersion\Windows

Now I haven't tested if the latter changes every time based on the version of the pvengine.exe you launch. I'll modify the AIOI in order to look first for the path in CurrentVersion (looking for an already installed POV) and if no key is found I'm going to assume that you've installed 3.6 included in the AIOI. If none of these keys is found you'll have to write the LGEO paths yourself.

Remarks?

w.

LEGO ergo sum
SubjectAuthorViewsPosted
AIOI problem when installed on a drive other than C:\ james2vegas691April 24, 2013 01:52AM
Re: AIOI problem when installed on a drive other than C:\ Willy Tschager286April 25, 2013 03:05PM
Re: AIOI problem when installed on a drive other than C:\ Max Martin Richter268April 25, 2013 10:42PM
Re: AIOI problem when installed on a drive other than C:\ Roland Melkert277April 26, 2013 11:38AM
Re: AIOI problem when installed on a drive other than C:\ Stephen265April 27, 2013 01:51AM
Re: AIOI problem when installed on a drive other than C:\ Willy Tschager247April 30, 2013 01:32AM
Re: AIOI problem when installed on a drive other than C:\ Stephen288April 30, 2013 02:21AM
Re: AIOI problem when installed on a drive other than C:\ Willy Tschager265June 15, 2013 03:24AM
Re: AIOI problem when installed on a drive other than C:\ Stephen244June 16, 2013 06:59AM
Re: AIOI problem when installed on a drive other than C:\ Willy Tschager398July 10, 2013 09:57AM



Sorry, only registered users may post in this forum.

Click here to login