Welcome! Log In Create A New Profile

Advanced
Re: Trouble with adding new primitives.
avatarAugust 04, 2013 12:45AM
Thanks for the reply, Chris.

I do tend to agree that they are more than just studs... they're more like "underside architecture." Now, initially, I did just create the "low-res" versions and thought about leaving it at that.

The problem arises out of the fact that for some (possibly all) of these parts, there are two variations: the "low-res" version and the "high-res" versions. I personally own both variations of the 4x6, and the above photo from Brickshelf proves that there are two versions of the 8x8 as well. I do not own and haven't found proof of the others (although I haven't really looked that hard), but I don't think it's a stretch to imagine the others might have this same variation as well.

Now, none of this would matter if LEGO had given them different part numbers, because then I could just create both versions seperately. Unfortunately, they didn't. Further, it wouldn't have bothered me as much if one of the already official parts (30400) wasn't already "high-res."

Still further, I could have simply created a regular, "low-res" version "xxxx.dat" and a "high-res" version "xxxxh.dat" (or something similar). Except somebody already did this with Baseplates, and everyone started arguing about precidents and not wanting to have multiple files for the same part. (Never mind that some parts have 2-3 or more numbers on the PT due to aliases.)

So, I set out to create a solution that would allow us to have both versions without causing problems on the PT. Is it perfect? No. But I can't think of a better way to do it. If anybody can, I'm open to suggestions.


P.S. I've started working on Steffen's solution to the Baseplate problem (although I'm going to have to make some small modifications to it in order to allow for rounded corners). Look for more on that soon.
SubjectAuthorViewsPosted
Trouble with adding new primitives. Jude Parrill330August 02, 2013 04:38PM
Re: Trouble with adding new primitives. Jude Parrill133August 02, 2013 04:49PM
Re: Trouble with adding new primitives. Philippe Hurbain150August 02, 2013 11:19PM
Underside detail - was Re: Trouble with adding new primitives. Jude Parrill151August 03, 2013 07:09AM
Re: Trouble with adding new primitives. Max Martin Richter131August 03, 2013 07:54AM
Re: Trouble with adding new primitives. Jude Parrill154August 03, 2013 03:05PM
Re: Trouble with adding new primitives. Chris Dee155August 03, 2013 10:56PM
Re: Trouble with adding new primitives. Jude Parrill148August 04, 2013 12:45AM
Re: Trouble with adding new primitives. Chris Dee157August 04, 2013 01:00AM
Re: Trouble with adding new primitives. Jude Parrill166August 04, 2013 01:47AM
Re: Baseplate underside detailing Chris Dee155August 04, 2013 03:01AM
Re: Baseplate underside detailing Santeri Piippo148August 04, 2013 03:34AM
Re: Trouble with adding new primitives. Jude Parrill143August 10, 2013 07:29PM
Re: Trouble with adding new primitives. Santeri Piippo179August 11, 2013 03:15AM
Re: Trouble with adding new primitives. Jude Parrill128August 03, 2013 05:58PM



Sorry, only registered users may post in this forum.

Click here to login